[SOLVED] Third-party library MUMPS compilation fails with gcc 7.1.1 (.ro-data errors)

I experienced some compilation problems on MUMPS with gcc 7.1.1.
It seems that MUMPS examples fails to build. The build process fails during the link.

The solution is to not compile the examples until a fix is provided upstream.
I modified the build script to only compile the library (commit 2610bb71 of notus_third_party).

If you experienced this error, I suggest the following protocol:

  • Refresh your ‘notus_third_party’ repository:

git pull

  • Clean up your repository. Git has an awesome tool for this:
    Warning: It will remove everything that is not followed by Git.

git clean -x -d -f

  • Rebuild everything:

./build_notus_third_party_lib.sh -a

Today I tried to compile MUMPS with examples again by doing

git revert 2610bb71

(in notus_third_party). Although now I am with GCC 7.2.0, and it works!

Thanks for the update!

If your system is not up-to-date and you have an old GCC version, it is safe to not revert the commit yet since the MUMPS examples are not required to build Notus.